Welcome! Log In Create A New Profile

Advanced

SSE Support Required ??

Posted by Anonymous User 
Anonymous User
SSE Support Required ??
January 21, 2014 05:01AM
Running PeerBlock 1.1 without problems
-
New version 1.2 announced 14 Jan 2014 - Downloaded today {20 Jan}.
I attempted to install it - - but this new version requires SSE support and this is not built into the processor I currently use in my internet isolation box. I am running the current version of Win-XP without difficulty. Processor is a 900MHz AMD Athlon. Ancient, but quite adequate for surfing, P2P, and E-Mail.
-
Am I stuck with PeerBlock Version 1.1 forever - or will there be updates that do NOT require SSE support ??
Re: SSE Support Required ??
January 22, 2014 07:32AM
avatar
Yes, with this release we enabled SSE support, in the hopes that it would improve performance somewhat.  Unfortunately this does mean that some old hardware will not be able to run newer versions of PeerBlock.  If we see a lot of users who are being impacted by this we might reconsider, or generate a special non-SSE build . . . but at this point there are no such plans, sorry.

Out of curiosity, have you checked the power consumption of this machine, multiplied out by the cost-per-watt your electric company charges you?  I had an older machine like that I was using for awhile as an always-on home server, until I did the math myself and discovered that a new higher-efficiency machine would actually pay for itself within a few months of decreased electricity consumption.  Might be worth doing the comparison, you might actually find that you can't afford not to upgrade that machine!

        ---  Mark  ---




Lead developer of PeerBlock
fxm
Re: SSE Support Required ??
January 22, 2014 01:45PM
MarkSide Wrote:
-------------------------------------------------------

> with this release we enabled SSE support, in
> the hopes that it would improve performance
> somewhat. 

Did you do any benchmarks?

Given the performance hit when SSE/non-SSE instructions are interspersed, It is not easy to picture what PB could be doing that would show a net gain - especially when PB is already limited by network and stack overhead.
Re: SSE Support Required ??
January 22, 2014 02:19PM
fxm Wrote:
-------------------------------------------------------
> MarkSide Wrote:
> --------------------------------------------------
> -----
>
> > with this release we enabled SSE support, in
> > the hopes that it would improve performance
> > somewhat. 
>
> Did you do any benchmarks?

No.



Edited 1 time(s). Last edit at 01/22/2014 02:19PM by Keefa.
Anonymous User
Re: SSE Support Required ??
January 23, 2014 03:57AM
Hi - - Mark:
Appreciate the update - -
True - - my machine is an older one - - however quite adequate for the tasks assigned to it.
I build my own computers - and have a 9TB NAS with VPN server enabled - - so am relatively knowledgable regarding IT issues - - however choose to use my more sophisticated machines for other tasks.
As others have mentioned - - I really doubt SSE will have any significant impact on connection throughput for most routine P2P activities.
-
I sincerely hope you will reconsider and recompile the current and future versions of PeerBlock with SSE disabled - - either that or make two versions available - - one with and the other without SSE. If your benchmarks really show a significant advantage to having SSE enabled - - I might be talked into using a different computer for my internet isolation sandbox - - however if there is no advantage, just because it's newer does NOT mean it's better.

Thanks
CyberSurfer
Re: SSE Support Required ??
February 07, 2014 04:06AM
avatar
SSE is used to improve code performance which means faster list generating and less system impact (ram / cpu) consumption while doing it. Also the use of newer coding decreases the likelihood of crashes. Overall the move to SSE was an informed decision. Older machines while good for what they are used for are in a word archaic and like Mark said power hogs. I can build a sse compatible system for under $100 and that as Mark said would save you money and give your setup a much needed upgrade. XP is soon loosing its security patch release cycle soon. So it might be time to upgrade all xp machines anyhow. otherwise it will be a huge security flaw network wide. I know of about 18 security flaws that can cripple xp and they are not on a patch list that microsoft is planning to patch by the time its life cycle runs out. I think in April... Come the end of XP comes a lot of head aches for consumers because with out the promise of security flaw patches comes the long waited for dream of hackers. There is right now over 1/3 the machines on the shelf for use running XP. That is a huge hole to fill and a computer techs dream.


So all in all a system upgrade might be just what the techie ordered.



Edited 2 time(s). Last edit at 02/07/2014 04:12AM by DarC.
Anonymous User
Re: SSE Support Required ??
April 20, 2014 04:17PM
Thanks all - - appreciate the feedback - -
Nothing wrong with 'archaic' systems - - IF they get the job done.
My old XP box (an isolation machine) does just that. And if it gets infected, I reload the HDD from an image backup, and no harm done. You REALLY can't beat XP for such an application - - unless of course - - you move to Linux - - which I may try in a few years.
I only run my isolation box for a few hours per week (typically) - - so the difference in power consumption really wouldn't make a divot in a world of green.
I hate to see a marvellous product such as PeerBlock leave 'legacy' machines in the dust - - the time and $$$ it would take me to build a NEW isolation box just doesn't make it worthwhile.
It MAY be possible to replace my older Athlon 908MHz processor with a newer one that DOES support SSE (IF I can find one that old ?? ) - - but unknown what the other impacts might be - - would likely have to change system clocks and other fiddlings - - not sure if the XP HAL would play nice with the new processor ??

So - - for now - - looks like I'm STUCK with PeerBlock 1.1

CyberSurfer
Anonymous User
Re: SSE Support Required ??
April 20, 2014 06:30PM
OK - - Fine - -
Just dropped $13 to buy an Athlon XP-2600+ Thoroughbred processor.
Should go into my 'Ancient' computer, boost it to 1.9GHz, and enable SSE
The things I have to do to keep up with software
Sorry, only registered users may post in this forum.

Click here to login