Welcome! Log In Create A New Profile


Driver Error

Posted by Anonymous User 
Anonymous User
Driver Error
February 02, 2010 03:02AM
Hi, I've recently upgraded my OS and now im getting this error when I try to start PeerBlock.
OS: Windows 7 Ultimate 64-bit
Version: PeerBlock 1.0+ (r223)

[2/1/2010] [21:50:10.985] [04084] [driver] [load(2)] preparing to load driver - name: [pbfilter], file: [\??\D:\xPeerBlock_r223__x64_Release_(Vista)\pbfilter.sys]
[2/1/2010] [21:50:10.985] [04084] [driver] [load(3)] loading driver - name: [pbfilter], file: [\??\D:\xPeerBlock_r223__x64_Release_(Vista)\pbfilter.sys], devfile: [\\.\pbfilter]
[2/1/2010] [21:50:11.235] [04084] [driver] [load(3)] driver-service not running
[2/1/2010] [21:50:11.235] [04084] [driver] [load(3)] - service state: [1]
[2/1/2010] [21:50:11.235] [04084] [driver] [start] starting driver
[2/1/2010] [21:50:11.250] [04084] [driver] [start] * Error: ERROR: StartService
[2/1/2010] [21:50:11.250] [04084] [driver] [start] - err:[5], desc:[Access is denied.

Any ideas?

I couldnt find any other posts about this. If it is a duplicate feel free to delete it.

Edited 1 time(s). Last edit at 02/02/2010 03:03AM by notta.
open | download - PeerBlockError.png (28.4 KB)
Re: Driver Error
February 02, 2010 02:27PM
Looks like Windows isn't letting us load the pbfilter.sys driver for some reason.  Where is the D:\xPeerBlock_r223__x64_Release_(Vista) directory?  On a local harddrive?  USB flash stick?  Network share?  Is it safe to assume you unzipped the "Portable" .zip version of PeerBlock into this directory, instead of running the installer?  I'm assuming you're running as Administrator, otherwise PeerBlock should have complained earlier in the startup process, but can you confirm this?  Is your computer a member of a Domain, such that some Group Policies may be in effect that are preventing you from loading this driver?  Anything interesting show up in the Event Logs from around this timeframe?

Sorry for all the questions, just trying to get a better handle as to what's causing this problem...

        ---  Mark  ---

Lead developer of PeerBlock
Anonymous User
Re: Driver Error
February 02, 2010 05:33PM
D:\ is a partition of my main harddrive.
-I've tried launching it from removable media, root of my main partition, my desktop, etc
It is the portable version.
It is being ran as the admin.
No activity in the Event Logs.
And its not a member of a domain.

I also tried transferring the folder to 2 other computers.
It worked on both of them.
Also re Downloaded a "clean" version of PeerBlock, thinking it was my config or something.
But it gave the same error.

I did find this though...
My firewall promoted me with the attached dialog.
Of course, I allowed it.
Re: Driver Error
February 02, 2010 10:02PM
Hmm, did you tell Comodo to "Remember my answer"? Wondering if maybe we never recovered from their initial block/stall of our attempt to install/start the service (which is what causes these registry updates). As a test, could you try adding peerblock.exe to Comodo's "trusted programs" list?

        ---  Mark  ---

Lead developer of PeerBlock
Anonymous User
Re: Driver Error
February 02, 2010 11:01PM
hmmm...ok now i feel like an idiot.
The problem was that windows encrypted the folder.
I cleared it and PeerBlock started right up.

In case someone else is experiencing the same problem:
The folder name will show up green.
Right click the folder > Properties > Advanced(on the general tab) > Uncheck "Encrypt contents to secure data"
Apply to all + sub directories.

Thanks for the help Mark
Hope my experience can help someone else.

Edited 2 time(s). Last edit at 02/03/2010 10:19PM by notta.
Sorry, only registered users may post in this forum.

Click here to login