Welcome! Log In Create A New Profile

Advanced

HELP!PeerBlock cannot be launched!!

Posted by Anonymous User 
Anonymous User
HELP!PeerBlock cannot be launched!!
March 06, 2010 08:56AM
Hello...I´ve been using, at first, PeerGuardian and, then, PeerBlock v1.0.0.r181 with no problems...I don´t know why ( maybe something to be with Comodo Firewall?) but a couple of days ago, PeerBlock stopped to work, or better, could not be launched. I use Windows XP Professional SP3 and the general msg is:

" PeerBlock is unable to load the packet filtering driver. This could happen if PeerBlock crashed and didn´t have a chance to unload the file or if the file pbfilter.sys can´t be found".

Well, since the file pbfilter.sys exists, I decided to remove PeerBlock completely, turn off my PC, wait for some minutes, turn on my PC again choosing Comodo Firewall´s Training Mode option and install the software downloaded from PeerBlock website.

Unfortunately, besides the msg above, I got these following ones:

"Open Service
1060
The specified service does not exist as an installed service"

What the heck is going one? PeerBlock is a very useful tool for me since I use P2P applications a lot...Please, help me to restore it!

Thanks a lot.
Re: HELP!PeerBlock cannot be launched!!
March 06, 2010 09:03AM
Heya ViVi_2008.

I'm sorry to hear you experiencing this problem. Have you tried the latest beta? I recall the latest beta had this issue fixed.
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 06, 2010 09:25AM
The Beta version showed the same msg above! A "class win32_error".

What´s going on after all? May that means I´ve got a virus/malware in my PC no matter my latest and up-to-dated freeware Avira Anti-virus software seems to be working...????

Everything happened just 2 days ago!!!!! Before that time, PeerBlock always worked wonderfully...:-(

Btw, this its log file:

Logging Started...
[3/6/2010] [12:17:51.250] [04012] PeerBlock Starting
[3/6/2010] [12:17:51.250] [04012] PeerBlock 1.0+ (r277) - BETA RELEASE
[3/6/2010] [12:17:51.265] [04012] Flushed tracelog
[3/6/2010] [12:17:51.265] [04012] Running on OS: Windows XP 32-bit - Build:[2600], SP:[3.0]
[3/6/2010] [12:17:51.265] [04012] User running as Admin
[3/6/2010] [12:17:51.265] [04012] Created program mutex
[3/6/2010] [12:17:51.406] [04012] Initialized common controls
[3/6/2010] [12:17:51.406] [04012] Registered color picker
[3/6/2010] [12:17:51.406] [04012] Initialized winsock
[3/6/2010] [12:17:51.406] [04012] Successfully PreventSetUnhandledExceptionFilter()
[3/6/2010] [12:17:51.406] [04012] Creating main UI window
[3/6/2010] [12:17:51.718] [04012] [mainproc] [Main_OnInitDialog] > Entering routine.
[3/6/2010] [12:17:51.718] [04012] [mainproc] [Main_OnInitDialog] loading config
[3/6/2010] [12:17:51.718] [04012] [Configuration] [Load] > Entering routine.
[3/6/2010] [12:17:51.734] [04012] [Configuration] [LoadFile] loading file:[C:\Arquivos de programas\PeerBlock\peerblock.conf]
[3/6/2010] [12:17:51.734] [04012] [Configuration] [LoadFile] * Error: Can't open file
[3/6/2010] [12:17:51.734] [04012] [Configuration] [LoadFile] - err:[2], desc:[O sistema não pode encontrar o arquivo especificado.

]
[3/6/2010] [12:17:51.734] [04012] [Configuration] [LoadFile] loading file:[C:\Arquivos de programas\PeerBlock\peerblock.conf.bak]
[3/6/2010] [12:17:51.750] [04012] [Configuration] [LoadFile] * Error: Can't open file
[3/6/2010] [12:17:51.750] [04012] [Configuration] [LoadFile] - err:[2], desc:[O sistema não pode encontrar o arquivo especificado.

]
[3/6/2010] [12:17:51.750] [04012] [Configuration] [LoadFile] loading file:[C:\Arquivos de programas\PeerBlock\pg2.conf]
[3/6/2010] [12:17:51.750] [04012] [Configuration] [LoadFile] * Error: Can't open file
[3/6/2010] [12:17:51.750] [04012] [Configuration] [LoadFile] - err:[2], desc:[O sistema não pode encontrar o arquivo especificado.

]
[3/6/2010] [12:17:51.750] [04012] [Configuration] [Load] WARNING: No configuration file found.
[3/6/2010] [12:17:51.750] [04012] [mainproc] [Main_OnInitDialog] displaying first-time wizard
[3/6/2010] [12:18:01.437] [04012] [Configuration] [Save] > Entering routine.
[3/6/2010] [12:18:01.484] [04012] [Configuration] [Save] < Leaving routine.
[3/6/2010] [12:18:01.484] [04012] [mainproc] [Main_OnInitDialog] resetting g_filter
[3/6/2010] [12:18:01.484] [04012] [pbfilter_nt] [pbfilter] > Entering routine.
[3/6/2010] [12:18:01.484] [04012] [pbfilter_nt] [pbfilter] loading microsoft IpFilterDriver
[3/6/2010] [12:18:01.484] [04012] [driver] [load(2)] preparing to load driver - name: [IpFilterDriver], file: [System32\Drivers\IpFltDrv.sys]
[3/6/2010] [12:18:01.484] [04012] [driver] [load(3)] loading driver - name: [IpFilterDriver], file: [System32\Drivers\IpFltDrv.sys], devfile: [\\.\IpFilterDriver]
[3/6/2010] [12:18:02.421] [04012] [driver] [load(3)] driver not currently installed as service
[3/6/2010] [12:18:02.421] [04012] [driver] [load(3)] service name: [system32\DRIVERS\ipfltdrv.sys], file name: [System32\Drivers\IpFltDrv.sys]
[3/6/2010] [12:18:02.421] [04012] [driver] [load(3)] driver-service not running
[3/6/2010] [12:18:02.421] [04012] [driver] [load(3)] - service state: [1]
[3/6/2010] [12:18:02.421] [04012] [pbfilter_nt] [pbfilter] starting IpFilterDriver
[3/6/2010] [12:18:02.421] [04012] [driver] [start] starting driver
[3/6/2010] [12:18:02.421] [04012] [driver] [start] flagging driver as not stoppable
[3/6/2010] [12:18:02.437] [04012] [driver] [start] started driver
[3/6/2010] [12:18:02.437] [04012] [pbfilter_nt] [pbfilter] loading pbfilter.sys
[3/6/2010] [12:18:02.437] [04012] [driver] [load(1)] preparing to load driver - name: [pbfilter]
[3/6/2010] [12:18:02.437] [04012] [driver] [load(2)] preparing to load driver - name: [pbfilter], file: [C:\Arquivos de programas\PeerBlock\pbfilter.sys]
[3/6/2010] [12:18:02.437] [04012] [driver] [load(3)] loading driver - name: [pbfilter], file: [C:\Arquivos de programas\PeerBlock\pbfilter.sys], devfile: [\\.\pbfilter]
[3/6/2010] [12:18:02.453] [04012] [driver] [load(3)] driver not currently installed as service
[3/6/2010] [12:18:02.453] [04012] [driver] [load(3)] ERROR opening service
[3/6/2010] [12:18:02.453] [04012] [driver] [close] > Entering routine.
[3/6/2010] [12:18:02.453] [04012] [driver] [close] closing driver - name: [IpFilterDriver]
[3/6/2010] [12:18:02.453] [04012] [driver] [stop] > Entering routine.
[3/6/2010] [12:18:02.453] [04012] [driver] [stop] Tried to stop driver, but it is not flagged as a stoppable driver
[3/6/2010] [12:18:02.453] [04012] [driver] [stop] < Leaving routine (without doing anything).
[3/6/2010] [12:18:02.453] [04012] [driver] [close] unloaded driver
[3/6/2010] [12:18:02.453] [04012] [driver] [close] < Leaving routine.
[3/6/2010] [12:18:02.453] [04012] [driver] [close] > Entering routine.
[3/6/2010] [12:18:02.453] [04012] [driver] [close] closing driver - name: [pbfilter]
[3/6/2010] [12:18:02.453] [04012] [driver] [close] Tried to close driver, but it wasn't loaded.
[3/6/2010] [12:18:02.453] [04012] [driver] [close] < Leaving routine (without doing anything).
[3/6/2010] [12:18:06.015] [04012] [mainproc] [Main_OnDestroy] destroying main window
[3/6/2010] [12:18:06.015] [04012] [mainproc] [Main_OnDestroy] writing config out to disk
[3/6/2010] [12:18:06.015] [04012] [Configuration] [Save] > Entering routine.
[3/6/2010] [12:18:06.046] [04012] [Configuration] [Save] < Leaving routine.
[3/6/2010] [12:18:06.046] [04012] [mainproc] [Main_OnDestroy] finished saving config to peerblock.conf
[3/6/2010] [12:18:06.046] [04012] [mainproc] [Main_OnDestroy] deleting tray icons
[3/6/2010] [12:18:06.046] [04012] [mainproc] [Main_OnDestroy] tray icons destroyed
[3/6/2010] [12:18:06.046] [04012] [mainproc] [Main_OnDestroy] Terminating program...
[3/6/2010] [12:18:06.046] [04012] [mainproc] [Main_OnDestroy] post quit message
[3/6/2010] [12:18:06.046] [04012] Created main UI window
[3/6/2010] [12:18:06.046] [04012] [Configuration] [Save] > Entering routine.
[3/6/2010] [12:18:06.062] [04012] [Configuration] [Save] < Leaving routine.
[3/6/2010] [12:18:06.062] [04012] Starting message-loop
[3/6/2010] [12:18:06.062] [04012] Message loop ended, shutting down PeerBlock
[3/6/2010] [12:18:06.062] [04012] [mainproc] [Shutdown] Shutting down PeerBlock.
[3/6/2010] [12:18:06.062] [04012] [mainproc] [Shutdown] Shutting down winsock
[3/6/2010] [12:18:06.062] [04012] [mainproc] [Shutdown] Finished shutting down PeerBlock.
[3/6/2010] [12:18:06.062] [04012] PeerBlock is now exiting, due to user request.



Edited 1 time(s). Last edit at 03/06/2010 09:34AM by ViVi_2008.
Re: HELP!PeerBlock cannot be launched!!
March 06, 2010 09:52AM
I found this post (link: [forums.peerblock.com] ). Perhaps it'll help you. If it doesn't then I'm afraid you'll need to wait for someone more experienced to come help you.
Re: HELP!PeerBlock cannot be launched!!
March 06, 2010 11:18AM
avatar
When you uninstalled PeerBlock did you remove the PeerBlock folder located in C:\Program Files prior to re-installing?




This business is binary. You're either a one or a zero.
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 06, 2010 12:21PM
zerocoolxp Wrote:
-------------------------------------------------------
> When you uninstalled PeerBlock did you remove the
> PeerBlock folder located in C:\Program Files prior
> to re-installing?

Hope you can help me!
All the 3 times I removed the 2 versions of PeerBlock, I used REVO UNINSTALLER in its Advanced mode, which allowed me to erase everything in my PC related to PB, including all its Register keys...I am really tricky!

What do you want me to do?:-/



Edited 1 time(s). Last edit at 03/06/2010 12:23PM by ViVi_2008.
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 06, 2010 12:29PM
Tippy Wrote:
-------------------------------------------------------
> I found this post (link:
> [forums.peerblock.com]
> sg-2863 ). Perhaps it'll help you. If it doesn't
> then I'm afraid you'll need to wait for someone
> more experienced to come help you.


Thank you, Tippy...but I am sorry to say that was not helpful...:-(
Re: HELP!PeerBlock cannot be launched!!
March 07, 2010 02:55PM
avatar
Is there any instance of PGfilter.sys (not PBfilter.sys) if you search for it in the registry?

Also, have you tried to disable Comodo firewall and launch PB afterwards?




This business is binary. You're either a one or a zero.



Edited 1 time(s). Last edit at 03/07/2010 02:59PM by zerocoolxp.
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 07, 2010 04:05PM
Hello there!

zerocoolxp Wrote:
-------------------------------------------------------
> Is there any instance of PGfilter.sys (not PBfilter.sys) if you search for it in the registry?

Nope. Just ran AUTORUNS...nothing alike that file name is running here

> Also, have you tried to disable Comodo firewall and launch PB afterwards?

Unfortunately I did that ( even being, allow me to say, a dangerous warn) and got the same msg above...btw I reinstalled the estable version (r181). Log attached.

I see at [code.google.com] that I am not the only one to get that problem (Issue 75)...seems to be a serious bug to be reviewed and corrected. Am I wrong?
Attachments:
open | download - peerblock.log (24.2 KB)
Re: HELP!PeerBlock cannot be launched!!
March 07, 2010 05:45PM
avatar
have you tried a system restore yet? i know someone had a similar problem such as yours and they were able to fix it after a system restore.

like restore it to a date when PB WAS working, see if it works and let us know if you havent tried that yet.




Life is like a box of chocolates................................umm chocolate, yummy grinning smiley



Edited 1 time(s). Last edit at 03/07/2010 05:46PM by brandonjm8.
Re: HELP!PeerBlock cannot be launched!!
March 07, 2010 07:40PM
avatar
Has anything changed since it last worked? A windows update, driver update, any programs were installed? When you disabled Comodo did you stop all the services for it? I'm sure they were still running along with other Comodo processes. Have you tried uninstall it to test out? Would really help to nail that bug.




This business is binary. You're either a one or a zero.
Re: HELP!PeerBlock cannot be launched!!
March 07, 2010 08:46PM
avatar
Did you install Comodo when it started happening.
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 04:04AM
brandonjm8 Wrote:
-------------------------------------------------------
> have you tried a system restore yet? i know someone had a similar problem such as yours and
> they were able to fix it after a system restore.like restore it to a date when PB WAS working, see
> if it works and let us know if you havent tried that yet.

I did that and everything is the same here...sorry :-(
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 04:23AM
zerocoolxp Wrote:
-------------------------------------------------------
> Has anything changed since it last worked? A windows update, driver update, any programs were
> installed? When you disabled Comodo did you stop all the services for it? I'm sure they were still
> running along with other Comodo processes. Have you tried uninstall it to test out? Would really
> help to nail that bug.

I am sure you wanna help me out and i thank you all you for your attempts however, as I told above, Issue 75 shows there is a serious bug that is somehow started by some action...I remember, for instance, to be obliged disable my system restore for a few minutes a few days ago...don´t recall why I had to do that and cannot remember if PeerBlock stopped working after that...what I wanna say is that for sure some something abnormal - what? when?it´s very difficult to recall - happened here which might probably affect PeerBlock...but then why its designers cannot solve my and other people´s problems who are getting the same messages from the system when they cannot load PeerBlock like me? Why is PeerBlock "unable to load the packet filtering driver"? No viruses or malwares there according to Avira Anti-Virus and my 2 anti-malware softwares....Tricky, odd, weird...
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 06:42AM
zerocoolxp Wrote:
-------------------------------------------------------
> Has anything changed since it last worked? A
> windows update, driver update, any programs were
> installed? When you disabled Comodo did you stop
> all the services for it? I'm sure they were still
> running along with other Comodo processes. Have
> you tried uninstall it to test out? Would really
> help to nail that bug.

I am sorry...I´ll not uninstall a crucial protection for my PC cos of a bug that is happening to several people (see, again, Issue 75) who btw are using other Firewall softwares...
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 06:58AM
I'm sorry if the suggestion of uninstalling a firewall offended you. It seems we are not sure what could've caused it since none of the folks at PeerBlock are experiencing this problem or able to reproduce this problem. Nor would it seem that anyone knows what in the code is making this error.

Only way for us to catch and fix this bug is by trying everything out one by one. Doing kind of stuffs like that grumpy doctor in some western program. Another way to help us find the source of the problem (or at least narrow it down) is for the user themselves (in this case you) to remember in exact detail what were they doing on their computer and what their computer was doing in the last 24 - 48 hours or earlier. Of course, remembering is not easy.



Edited 2 time(s). Last edit at 03/08/2010 07:10AM by Tippy.
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 08:19AM
avatar
something changed between the day it was working to the day IT STOPPED working, thats the info we need from you. you said so yourself that it was working for you prior but now its not, you also said something changed and now it appears it affected PB and it wont load properly.

you gotta help yourself and let us try to help you help yourself, k.

whatever is the problem is a stubborn one, this is gonna take some patience and trial and error and possibly an open mind. computers are like fingerprints, no two are alike, which makes it hard since what works for me isnt necessarily gonna work for you kinda thing, hang in there and we'll help you figure it out.




Life is like a box of chocolates................................umm chocolate, yummy grinning smiley
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 09:03AM
Tippy Wrote:
-------------------------------------------------------
> I'm sorry if the suggestion of uninstalling a
> firewall offended you. It seems we are not sure
> what could've caused it since none of the folks at
> PeerBlock are experiencing this problem or able to
> reproduce this problem. Nor would it seem that
> anyone knows what in the code is making this
> error.
>
> Only way for us to catch and fix this bug is by
> trying everything out one by one. Doing kind of
> stuffs like that grumpy doctor in some western
> program. Another way to help us find the source of
> the problem (or at least narrow it down) is for
> the user themselves (in this case you) to remember
> in exact detail what were they doing on their
> computer and what their computer was doing in the
> last 24 - 48 hours or earlier. Of course,
> remembering is not easy.

Sorry, Tippy, if I offended you...however I remember when I used PeerGuardian, I had to inform my Firewall its IP in order of not been blocking nevertheless PeerBlock is considered a Trusted Application by Comodo.

Frankly I have no clue of what made PeerBlock stop working...what I am aware is that there are a bunch of ppl with the same Issue (75) unsolved.
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 09:06AM
brandonjm8 Wrote:
-------------------------------------------------------
> something changed between the day it was working
> to the day IT STOPPED working, thats the info we
> need from you. you said so yourself that it was
> working for you prior but now its not, you also
> said something changed and now it appears it
> affected PB and it wont load properly.
>
> you gotta help yourself and let us try to help you
> help yourself, k.
>
> whatever is the problem is a stubborn one, this is
> gonna take some patience and trial and error and
> possibly an open mind. computers are like
> fingerprints, no two are alike, which makes it
> hard since what works for me isnt necessarily
> gonna work for you kinda thing, hang in there and
> we'll help you figure it out.

I am pretty sure one of you is going to fix it...Meanwhile, of course, my only alternative is to wait...And I thank all you a lot for trying to help me...:-) no matter PeerBlock is dead here...:-(
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 11:24AM
avatar
The problem here appears to be that when we attempt to load our driver, Windows is not letting us create the service wrapper around it.  Not sure why this is happening, we need to add some additional debug code around it to hopefully pull out some more information when it occurs, and then see what we can do to work around the problem.

We're working on releasing a new Beta Release right now, after that we'll get that additional debug-code put in and post a pointer to a "test version" of PeerBlock - probably to the bug you referenced earlier, Issue #75, so that the other 14 people who've Starred that bug will receive notification and be able to collect some additional data for us too.

In the meantime, the people who've been trying to help you here are pretty much forced to grasp at straws.  We have seen many instances of third-party software - generally firewalls / antivirus - interfering with PeerBlock's operation, particularly on XP, which is why they'd initially targetted that for an attempt to narrow down the root cause of the problem.

In any event, thank you for your patience thus far.  Rest assured that we are looking into this problem, and like I said hope to have a special test-version built soon to help us chase this down.

        ---  Mark  ---




Lead developer of PeerBlock
Anonymous User
Re: HELP!PeerBlock cannot be launched!!
March 08, 2010 12:21PM
Mark, I am going to repeat the same words I´ve just emailed to you:
"Thank you for your prompt response. Well, I am crossing my fingers here for you! My sincere wishes of best luck to get PB fixed asap".
Sorry, only registered users may post in this forum.

Click here to login