Welcome! Log In Create A New Profile

Advanced

Not blocking anything

Posted by Anonymous User 
Anonymous User
Not blocking anything
March 25, 2010 09:36PM
I'm using Peerblock 1.0 r181. On first glance everything appeared to be working fine. I on purposely tried to go to a site that I knew should be blocked, and discovered that Peerblock was in-fact not blocking anything. Which kinda upsets me because I've been torrenting for a few days with NO PROTECTION.

I've checked the issues link, I've read numerous threads here, I've also checked the FAQ's. But here in the "HOW DO I KNOW IF PEERBLOCK IS WORKING" article, it says "after you ping 3.0.0.0. (general electric), and if PeerBlock is not working, the ping command should return "Request timed out" and the PeerBlock UI will show this access as Allowed"

However, there is no SOLUTION or REMEDY for this. My blocked connections are suppose to be RED. On peerblock (hopefully my attachment shows) it shows it as being RED (blocked) but its not really blocking nothing.

Any idea's?
Attachments:
open | download - peerblock.rar (5.4 KB)
open | download - Peerblock.jpg (211.4 KB)
Re: Not blocking anything
March 25, 2010 10:07PM
This is a know issue.

If you could uninstall your PeerBlock 1.0, and install a the latest Beta copy " PeerBlock r320 " at [code.google.com]

Now reboot the computer, and retry.

If it's still not working, the next step is to disable/re-enable PeerBlock

If still not working, try deleting all C:\Program Files\PeerBlock\lists\*.list files (but explicitly NOT the *.p2p files), and click Check Updates

( Copied from MarkSide, lead developer PeerBlock )
Re: Not blocking anything
March 25, 2010 10:07PM
avatar
Try installing the latest beta. R181 hasn't been worked on since Sept 2009.




This business is binary. You're either a one or a zero.
Anonymous User
Re: Not blocking anything
March 25, 2010 10:15PM
Ineedalife- I apologize, but I thought the r181 was the latest, i just downloaded it 3 days ago. But sure, I will be more than glad to reinstall using r320. But I have already tried the disable/re enable trick, to no avail on this version. I will report back if it works correctly with the new build. And if it does, maybe a sticky should be posted encouraging all new members/downloaders to try build r320 first, as its most reliable.

zero- Thanks for the input. And for the record, if that picture is a picture of you, then what I'd like to know is "Will you take me to be your lawful wedded PSYB0RG? Goodness gracious!
Anonymous User
Re: Not blocking anything
March 25, 2010 10:42PM
UPDATE:

Just installed the r320 build. Its blocking GE 3.0.0.0 flawlessly. But I tried to go to DEPT OF DEFENSE (since they are usually prying) but it allowed me to go straight into their domain with no problems. Unless they have been taken off the block list, I have no idea why I was able to connect to them. I was also able to connect to another GOV site with no problem. it did block me from connecting to the local COUNTY GOV tho, so I have no idea whats going on now?

Maybe I need to try more GOV sites, Any suggestions?

NEW UPDATE:
now it appears to not be blocking anything at all. I've tried disable/re enable again, restarting my pc, im out of ideas.



Edited 1 time(s). Last edit at 03/26/2010 06:42AM by PSYB0RG.
Re: Not blocking anything
April 06, 2010 08:53AM
avatar
If PeerBlock's blocking anything on its list, it should be blocking them all.  I would expect that the specific IP addresses of the sites you were attempting to connect to were just not on any of your blocklists at the time.

As far as PeerBlock truly not blocking anything, this is in fact a problem some people have been seeing.  Please see this post for more details.  Like I said in that post, I'm very sorry we haven't been able to completely nail this problem down yet.  sad smiley

        ---  Mark  ---




Lead developer of PeerBlock



Edited 1 time(s). Last edit at 04/06/2010 10:38AM by MarkSide.
Sorry, only registered users may post in this forum.

Click here to login