Welcome! Log In Create A New Profile

Advanced

"Driver Error" CreateService 1072

Posted by Anonymous User 
Anonymous User
"Driver Error" CreateService 1072
April 21, 2010 03:32PM
Tried a fresh install btw, with the newest beta release. But I still get the same error. Here's the error message with log attached. Cheers.
---------------------------
Driver Error
---------------------------
PeerBlock is unable to load the packet filtering driver.

This is likely the result of some strange bug. Please report this error, including all information that follows, to the PeerBlock team at [forums.peerblock.com]. Thank you for helping us improve PeerBlock!



class win32_error

CreateService

1072

The specified service has been marked for deletion.


---------------------------
OK
---------------------------
Attachments:
open | download - peerblock.log (16 KB)
Re: "Driver Error" CreateService 1072
April 21, 2010 05:06PM
try this

uninstall PeerBlock
restart the computer
install PeerBlock
Anonymous User
Re: "Driver Error" CreateService 1072
April 21, 2010 05:25PM
ineedalifetoday Wrote:
-------------------------------------------------------
> try this
>
> uninstall PeerBlock
> restart the computer
> install PeerBlock


Full uninstall, lists and configs included?
Re: "Driver Error" CreateService 1072
April 21, 2010 06:12PM
leave the lists and config
Anonymous User
Re: "Driver Error" CreateService 1072
June 11, 2010 05:22PM
I get the _EXACT_ same 1072 error every time I re-open PeerBlock, i.e. it starts fine the first time after a reboot, but fails to start on every subsequent attempt. Log file attached.

I know there are bugs like this which are reported to be resolved, but I am still having this problem.

I run Win XP SP3. I have this problem with the latest stable release and r131, r320, r404. With the latter, I uninstalled PB, rebooted, then reinstalled, as suggested above.

N.B.: My system is an upgrade from Win NT (yrs ago), so the usual C:\Windows folder is C:\Winnt.

PB works fine on my laptop, which is a direct install of XP and C:\Windows is present.

Thanks for any help!
Attachments:
open | download - peerblock.log (33.4 KB)
Re: "Driver Error" CreateService 1072
June 11, 2010 07:41PM
avatar
Interesting...  Thank you for the peerblock.log file, this is the first one I've seen relating to this problem.

What it looks like is happening in your case, beej9, is that on the first run we're successfully starting our pbfilter.sys driver, then running for however long, then when you exit we're stopping that driver and deleting it.  The next time you start PeerBlock during this boot, we attempt to start pbfilter.sys but Windows tells us it can't be started because the driver's "wrapper" service has been marked for deletion.  This means that our previous attempt to delete the service never completed.  Because of this, the Windows "Service Control Manager" (SCM) refuses to let us restart the driver - it assumes it's still on its way down.

Tough to say why our driver isn't properly completing shutdown on this one machine.  Would you mind collecting some additional debug information to help troubleshoot this?  This thread-post has instructions for using Microsoft's DebugView tool to generate some additional data for us.  Ignore the stuff about installing that r226 release, but please run through steps #1-8 and post your logfiles (both peerblock.log as well as the debugview output) here.

Thanks in advance, and hopefully we'll be able to get a better understanding of the problem you're hitting here.

        ---  Mark  ---

[Edited to include the actual link to the DebugView thread-post]




Lead developer of PeerBlock



Edited 1 time(s). Last edit at 06/11/2010 07:42PM by MarkSide.
Anonymous User
Re: "Driver Error" CreateService 1072
June 13, 2010 08:42AM
Mark,

Thanks for following up! I am attaching pbfilter.log and peerblock.log.

I rebooted, deleted the prior log files, started DebugView logging, then started PeerBlock (success). I then closed PeerBlock, and tried to start PeerBlock (error 1072). I stopped DebugView and posted the log files.

N.B.: When I restarted PeerBlock and got the error, there was no visible activity in the DebugView window, and I don't think the pbfilter.log has any sign that I attempted to start PeerBlock that second time.

Hope this helps, thanks!

Barry
Attachments:
open | download - pbfilter.log (7.4 KB)
open | download - peerblock.log (31 KB)
Anonymous User
Re: "Driver Error" CreateService 1072
December 08, 2010 04:03PM
I've been having the exact same problem since pg2.
PB loads and runs fine upon boot-up for however long, but as soon as I disable and exit,
I get:

class win32_error
CreateService
1072
The specified service has been marked for deletion.

Also running XP SP3.
Happens on all versions downloaded so far, including the latest stable release 1.1
This is about the only reason I reboot at all anymore... to restart the service.
Not driving me nuts at this point so I've been kinda sitting back and waiting.
Just wanted to pipe up and let someone know that this isn't an isolated bug to one machine.

Thanks for all the hard work.
JM
Anonymous User
Re: "Driver Error" CreateService 1072
December 30, 2010 09:54PM
Just an FYI I started getting this error and couldn't figure out what was going on, i'll sheepishly admit after a bit of searching I realized another user was still logged in with peerblock running which causes this error to pop up....might want to double check and make sure all other users are logged out.
Anonymous User
Re: "Driver Error" CreateService 1072
April 11, 2011 03:01PM
I had the same problem this exact error message, and my issue was that another user was logged in. This is mainly my remote desktop PC server, so although I was logged in as the same user since PeerBlock was already running it caused this error for me as well.

Soon as I killed the process for the other session it worked fine. Thanks Yellow Beard!
Sorry, only registered users may post in this forum.

Click here to login