Welcome! Log In Create A New Profile


Detected AP2P on Amazon EC2 cloud

Posted by LianelJoseph 
Detected AP2P on Amazon EC2 cloud
May 02, 2010 11:03PM
I'm currently using peer-block and when ever it blocks "Detected AP2P on Amazon EC2 cloud" my local Internet shuts off on my computer. I can still access Internet on other computers. How could I avoid this problem without allowing the ip to work?
Re: Detected AP2P on Amazon EC2 cloud
May 03, 2010 02:04AM
Hi LianelJoseph,

Welcome to the PeerBlock forums,

One of the dev's should be online shortly, and will be able to get back to you then.

Have a great day


Re: Detected AP2P on Amazon EC2 cloud
May 03, 2010 06:04AM
What do you mean by your local internet shuts off?

Can you still browse by allowing HTTP?
Re: Detected AP2P on Amazon EC2 cloud
May 03, 2010 12:21PM
Well my internet shuts off on the computer I'm currently running on peerblock. To fix it all I have to do is restart my machine but the ip is frequently blocked so I only have internet for a couple minutes. After the ip is blocked I can't browse any websites http or not and skype or torrenting don't work.
Re: Detected AP2P on Amazon EC2 cloud
May 10, 2010 10:52AM
No shutting down of connection here but this constant blocking of the same ip-range (Detected AP2P on Amazon EC2 cloud) as mentionned above, since a few weeks, when opening Vuze (with only 1 torrent from demonoid hanging there), or even when only browsing http (not downloading any files + with a guaranteed-clean & virus-free pc).
Any ideas?

Edited 1 time(s). Last edit at 05/10/2010 10:54AM by Pingu.
Re: Detected AP2P on Amazon EC2 cloud
May 12, 2010 08:58PM
Disable PB, then try a "netstat -b" in a command prompt window. It will show each connection, listening port and the program associated with it. Might reveal which app is connecting to that IP address.

This business is binary. You're either a one or a zero.
Re: Detected AP2P on Amazon EC2 cloud
May 13, 2010 10:59AM
definitely Vuze: i've deleted every pending torrents, the software itself & all related application-data's, reinstalled the latest version & as soon as the program start, this ip try to connect.
for the http occurrences, i'm waiting for the next hit to tell you more...
Re: Detected AP2P on Amazon EC2 cloud
June 10, 2010 09:29AM
I am having the same problem. It seems to me that Firefox is the culprit: every time I start it, I get the notice "Detected ap2p on amazon ec2 cloud". Which is weird, because I'd expect utorrent causing this. I've cleaned everything in Firefox, but it doesn't help.

Does someone have a solution for this? Because I don't want to use IE winking smiley


Re: Detected AP2P on Amazon EC2 cloud
June 10, 2010 09:40AM
I'm assuming these lines are in blue, for port 80, which means they're HTTP (web) type packets?

The thing to remember is that the various list-authors name IP ranges whatever they like.  So what is happening here in all likelihood, is that the folks over at Bluetack (who maintain the default lists PeerBlock uses) detected some anti-P2P activity coming from some of Amazon's "EC2 Cloud Computing" service, and added those IP addresses to the blocklist.  Now this EC2 service is also used for other, more legitimate purposes as well - for example by websites.  Since our IP blocking is an "all or nothing" affair, PeerBlock blocks both your P2P app as well as your Web Browser's access to these IP addresses. 

For the web-browser, these are probably benign, "innocent bystander" type services.  If blocking them is messing up certain websites on you, you can either Allow HTTP (and put up with the small TCP/port-80 "hole" in your defenses), or else temporarily Allow those IP addresses whenever you're visiting sites which won't work without access to 'em.  On the other hand if blocking them isn't causing you any additional grief, feel free to leave 'em alone.

Either way they're being blocked and - assuming these are in fact HTTP blocks - they're probably not indicative of any other problems.

Hope that helps,

        ---  Mark  ---

Lead developer of PeerBlock
Re: Detected AP2P on Amazon EC2 cloud
June 12, 2010 09:25AM
Could also be a toolbar, widget, app, etc. from Amazon.
Have a Kindle? Or use an eBook converter?
Have you ever downloaded from Amazon VOD, or MOD?
Or do you pass the connection through your system (hard bridge) from any other "unit" on your network?

While I wouldn't rule it "benign" at first glance, but I wouldn't really worry about it either if you're not doing anything naughty.

Just from my own experience:
I have the Amazon WishList extension installed on FireFox and GhostFox.
I have ALL Amazon set to block unless I click "allow HTTP".
I see this tagline all the time.
Even when blocking this line, I can add items to my wishlist using the toolbar.

My thoughts? Better safe than sorry. Block it. It won't kill you if you are using a "tool" and even if you are, it won't shut down anything of value.
Re: Detected AP2P on Amazon EC2 cloud
June 12, 2010 05:39PM

Nope, never used any of what you suggest or anything related to Amazon. & by the way, I've just visited Amazon's site to see what would happen & PeerBlock didn't mention any "Detected AP2P on Amazon EC2 cloud" while I was there...


It must be like you said...
I still get the same HTTP-block notice from time to time while browsing & definitely when using Vuze (i think I'll be switching to something else regarding torrents)


On my side, its not each time i start firefox that this happens, just sometime & not necessarily at start up.

Edited 2 time(s). Last edit at 06/13/2010 03:45AM by Pingu.
Re: Detected AP2P on Amazon EC2 cloud
July 21, 2010 02:12PM
When that message is coming up, at least for me, I'm using MySpace.
So, all-in-all, it's probably not a bad thing because odds are it's blocking the spyware/malware/spam
that MySpace has been known to give/cause.
However, that does sound rather annoying that it's blocking your Internet :/
But yeah, it's MySpace that's causing that to come up for me.
Not sure if it does the same on Facebook or Twitter, don't really use those two.
Re: Detected AP2P on Amazon EC2 cloud
July 24, 2010 05:16AM
Just yesterday same sh happened to me. But it was hard to catch.
I don't know if it was Peer block, or my firewall - same result - computer cold be connected only 30-60 sec, then internet fell off. Interesting thing, that i have router, and another PC works fine, so it was something from my end. I understood, that repairing the connection resumed it for another 30-60 sec. Now when i go to such sites, like [vark.com] i get the ap2p on amazon line, and seems to happen more often. I don't use torrents much, and such behaviour seems strange.

Also Limelight networks. Who the F are they? Have lots of blocks for them as well.
Re: Detected AP2P on Amazon EC2 cloud
July 27, 2010 11:05PM
The thing about Amazon EC2 is that it's a "cloud computing" provider.  This means that they have a bunch of virtual servers, that can be brought up/down on an as needed basis, using random IP addresses from the Amazon EC2 "pool".  This means that it's nearly impossible to determine which Amazon EC2 addresses are used by which service.  So for example vark.com might use Amazon EC2 for some of their server hosting; at the same time, J Random Botnet could also be using Amazon EC2 for their command-and-control servers.  Or a "bad guy" could be using Amazon EC2 to seed a fake / malware-ridden torrent.  Or could be using Amazon EC2 to trick other people into connecting to their EC2-hosted torrent-monitoring trackers.  And one hour vark.com could be using one EC2 IP address, then an hour later the Botnet could be using it, then an hour later a torrent-monitoring tracker, then an hour later vark.com again.

Because there is no way of knowing which of these IP addresses are currently being used by which service, some blocklist authors have added the entire Amazon EC2 range to their lists.  I believe the Bluetack Level1 (aka our "P2P") list did this after detecting some Anti-P2P activity coming from some services hosted within the Amazon EC2 cloud, so it's not a theoretical problem . . . it's real.

If the block is showing up in Blue, and you're currently browsing websites, this is likely "just" website-related traffic.  It could however be some other app or toolbar on your machine connecting to services hosted on Amazon EC2; good, bad, or otherwise.  I believe that recent Beta versions of uTorrent have included some feature that relies upon your machine being able to access their services on Amazon EC2 as well - one of their developers contacted me about this issue, but neither identified the feature nor responded to my initial (helpful, I thought) reply - so this may be a source of that blocked traffic as well.

As with anything else, you can feel free to allow connections to these IP addresses if you'd like.  Just remember that this means PeerBlock will no longer be blocking access to them, so that if someone is using Amazon EC2 for nefarious purposes you will NOT be protected.

Hope that helps,

        ---  Mark  ---

Lead developer of PeerBlock
Re: Detected AP2P on Amazon EC2 cloud
September 06, 2010 09:11AM
Is anyone seeing any activity related to : NebuAD, Inc;
if so, email me@ malleylaw@gmail.com

Joe malley
Re: Detected AP2P on Amazon EC2 cloud
March 18, 2011 02:07PM
I was just having the same issue. After going through all my services via services.msc - found that my gaming NIC card
was the culprit. It was Bigfoot killer 2000 service. Stopped it. Problem solved. Gave it permanent permission.
Re: Detected AP2P on Amazon EC2 cloud
April 17, 2011 01:00PM
I am having the same problem. Is there a way to click on a blocked ip addy and go to it? I know you can allow for 15/1 hr etc, but that is only if you know what it sending the signal. If we could 'visit the blocked ip' or something that would be great.
Re: Detected AP2P on Amazon EC2 cloud
April 17, 2011 04:37PM
fwiw a nice work around is just to approve the suspected links for 15 minutes or an hour and see if what you are trying to do works or not.
Re: Detected AP2P on Amazon EC2 cloud
September 14, 2011 05:37AM

For the past, say 2 months, I've been getting "detected AP2P on Amazon EC2 Cloud" on my peer block, its in blue, and the destination can be or, I have deleted anything that I felt may be causing it, and even did a full factory restore to the day I got my laptop, and it still is popping up, I have noticed it to show up when I'm on the internet, certain web pages brought up "Detected AP2P on Amazon EC2 Cloud " including while I was creating an account on this site to post this. After seeing it mainly comes up while I'm browsing the internet I'm not to worried about it, but still curious as to what it is? as I cannot find in any forum something that helps me.

Any feed back is really appreciated,
Re: Detected AP2P on Amazon EC2 cloud
January 30, 2012 12:18AM
I've noticed PeerGuardian has a Gov't list of blocked IP's does PeerBlock?

Think cosmic !!
Re: Detected AP2P on Amazon EC2 cloud
January 30, 2012 01:33AM
Re: Detected AP2P on Amazon EC2 cloud
July 02, 2014 12:28AM
ahah. a much more useful set of contributers in this forum, so please permit me to ask a question that has been bothering me for a while.
I get repeated "Checktor Blocked" (full details in the attached file) when I try to start my TorrentPrivacy App or open their website.
Do any of you above helpful people have a view on this matter? (Windows 7 Home PC - all up to date)
thanks a mil
open | download - Checktor Blocked.docx (1.93 MB)
Re: Detected AP2P on Amazon EC2 cloud
November 08, 2014 04:24AM
Omnipresent Amazon has turned out to be a real pest on the Internet and with torrents too. I've noticed that when I start up uTorrent, it always tries to connect to Amazon EC2 on port 80 (CurrentPorts clearly states that it is uTorrent trying to connect and not some other process) and also every time I close down uTorrent. In that respect it behaves a lot like with trackers. Could it be some trackers are hosted on an Amazon cloud service? But why would they connect on port 80?

...oh, I just had a look and saw that most of my torrents have those two trackers in their tracker list: udp://tracker.openbittorrent.com:80 and udp://tracker.publicbt.com:80 and those obviously do use port 80. I'll try removing those two when I have the time to watch it closer and see whether uTorrent still wants to connect to Amazon.
Re: Detected AP2P on Amazon EC2 cloud
November 08, 2014 06:04AM
OK, I just did a few tests and, so far, those two trackers mentioned by me that are using port 80, are not the culprits. (Phew, I'm so glad because I've been using those two also for my own torrent uploads.)

It turned out that in my set up a "test-torrent" that is available on the "ipleaks.net" test site keeps connecting to Amazon. The site itself does it too. That "test" torrent is supposed to check what your torrent IP looks like to an outsider (useful if you are hiding behind a VPN or a proxy).

I'll never use that test torrent again. I have yet two more test torrents (forget where I got them from) that do NOT connect to Amazon.

BTW, there are yet some more trackers out there that use port 80 and I haven't tested those yet. So, in YOUR case it could be one of those trackers trying to connect to Amazon. On my set up it was ONLY that test torrent responsible for the connection attempts. You can always test for yourself by removing and re-adding such trackers using port 80 from the tracker list in the torrent.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 23
Record Number of Guests: 215 on November 08, 2012