Welcome! Log In Create A New Profile

Advanced

This driver has been blocked from loading

Posted by Anonymous User 
Anonymous User
This driver has been blocked from loading
June 08, 2010 09:14AM
Hi there, sorry if this is a duplicate anywhere... I tried searching for this topic but couldn't find anything.

I receive this strange error everytime I try to start PeerBlock. Here is what is in the error message:

"PeerBlock is unable to load the packet filtering driver.

This is likely the result of some strange bug. Please report this error, including all information that follows, to the PeerBlock team at [forums.peerblock.com]. Thank you for helping us improve PeerBlock!

class win32_error
StartService
1275
This driver has been blocked from loading"

I will attach the logfile.

I am running Windows Server 2003 Datacenter x64 Edition SP2 as an administrator.

Thanks very much!
Attachments:
open | download - peerblock.log (15.7 KB)
Re: This driver has been blocked from loading
June 08, 2010 07:56PM
I don't know much about Windows Server 2003 ( or any of the different versions ) , but can you read this thread. It might fix your issue.


[forums.peerblock.com]
Anonymous User
Re: This driver has been blocked from loading
June 09, 2010 08:23AM
Thank you for your timely response. I had the same results as the original poster of that thread. Still no go on the starting of PeerBlock.
Re: This driver has been blocked from loading
June 10, 2010 09:05AM
avatar
Hmm, if I recall correctly Windows Server Datacenter versions require additional stuff before they'll allow kernel-mode drivers to load, over and above the basic "Signed Driver Needed" requirements of x64 Vista/7.  I believe Datacenter requires full WHQL/Logo testing, something we've not yet gone through.  Older versions (at least) also required that the entire system pass HCT testing, with all software/hardware/drivers loaded on the machine during this testing . . . and a pile of money to be handed over to MS as part of this process. 

Don't believe we'll be able to support running on Datacenter, unless someone can correct any mistaken remembrances I have of what's going on here...

        ---  Mark  ---




Lead developer of PeerBlock
Anonymous User
Re: This driver has been blocked from loading
June 10, 2010 01:05PM
Alright, thanks Mark. I'll keep an eye out to see if anything else comes along. Thanks for your time. smiling smiley
Re: This driver has been blocked from loading
June 10, 2010 03:29PM
avatar
Not having any problems with Server 2008 R2 x64 SP1. PeerBlock seems to work much better now with new r404 beta.
Anonymous User
Re: This driver has been blocked from loading
June 10, 2010 04:16PM
I see, I see. I grabbed r404 beta, tried it on 2003 Datacenter and still no good. But I'm thinking that what Mark said probably has a great deal to do with why it won't load. I'll be switching servers soon and I'll be looking for a 2008 R2 x64 now that you said it's worked for you. Let's hope it works for me as well. smiling smiley
Sorry, only registered users may post in this forum.

Click here to login