Welcome! Log In Create A New Profile

Advanced

Not a bug, just 'different'

Posted by Anonymous User 
Anonymous User
Not a bug, just 'different'
September 20, 2009 05:08PM
Hello, I am using the r162 release. For some reason this release is showing 9 allowed packets upon startup then says "stopped displaying allowed packets, for performance reasons blah blah" I have that option unchecked (show allowed connections) but it is showing them upon startup. Just thought you should know. I included 2 screen shots and the log file.
Attachments:
open | download - Screen 02.jpg (49.9 KB)
open | download - Screen 01.jpg (64.3 KB)
open | download - peerblock.log (24.6 KB)
Re: Not a bug, just 'different'
September 20, 2009 09:46PM
Did you read the blog ? tongue sticking out smiley

Quote

Default "Show Allowed" to False - On fresh installs, the "Show allowed connections" option will default to false. To keep people from thinking that PeerBlock isn't working if they don't see it doing anything, We're now automatically logging the first 9 or 10 Allowed packets regardless of your ShowAllowed setting, and after that logging a message explaining why we've stopped blocking them (presuming you have ShowAllowed set to false that is, of course).
[devblog.peerblock.com]
Re: Not a bug, just 'different'
September 20, 2009 11:09PM
avatar
Yes, Melerix got it.

One of peoples' common questions is always whether PeerBlock (or PG2, for that matter) is actually doing anything. Especially since we're now defaulting to disabling the "Show allowed connections" option on fresh installs, we wanted to make sure we didn't make this perception issue even worse - if people started it up but saw nothing, they would likely be more inclined to wonder whether PeerBlock was actually working or not.

So this was our compromise position. Log the first few packets, then log that message telling you we won't be logging anymore. One of our primary goals is Usability, so since you find this behavior confusing we should look into ways of clarifying it - I'd imagine you aren't the first person wondering about that. Any suggestions?

Thanks for the feedback,

        ---  Mark  ---




Lead developer of PeerBlock
Anonymous User
Re: Not a bug, just 'different'
September 20, 2009 11:26PM
I feel ashamed, I usually look at questions on forums and think to myself, "Why didn't this person google it? I am sure I could find this answer in .02 seconds." If I would of used my own advice I wouldn't have had to post this. Either way I am glad it got answered and keep up the good work.
Sorry, only registered users may post in this forum.

Click here to login